配置简单的单臂路由实现网络通信-综合-网络安全-我要学365体育投注人人小站_365体育投注打不开_皇冠365体育投注网址_我要学365体育投注人人小站_365体育投注打不开_皇冠365体育投注网址是一个面向开发者的知识分享网站 365体育投注人人小站_365体育投注打不开_皇冠365体育投注网址
我的位置:首页 > 综合>网络安全

配置简单的单臂路由实现网络通信

时间:2019-11-09 12:02:00 来源:互联网 作者: 神秘的大神 字体:

单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。

环境准备:思科模拟器

PC1:192.168.10.10

​ 255.255.255.0

​ 192.168.10.1

​ vlan10

PC2:192.168.20.10

​ 255.255.255.0

​ 192.168.20.1

​ vlan20

1573271224258

交换机配置

# 进入vlan模式,创建vlan
Switch#vlan database
Switch(vlan)#vlan 10
Switch(vlan)#vlan 20

# 进入接口,将vlan划分到接口中
Switch(config)#interface fastEthernet0/1
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 10

Switch(config)#interface fastEthernet0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20

# 将与路由器连接的端口设置为trunk模式
Switch(config)#interface fastEthernet0/3
Switch(config-if)#switchport mode trunk

路由器配置

# 开启与交换机连接的端口
Router(config)#interface fastEthernet 0/0
Router(config-if)#no shutdown

# 配置子接口的ip地址
Router(config)#interface fastEthernet 0/0.1
# 进入接口配置ip地址你会发现配置失败,是因为需要设置IEEE 802.1Q标准 协议后面的数字和vlan一致
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.10.1 255.255.255.0

Router(config)#interface fastEthernet 0/0.2
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 192.168.20.1 255.255.255.0

配置完成,我们试着ping一下,已经通信了

1573271194600