[Linux] centos6.5升级安装的supervisor-操作系统-Linux-我要学365体育投注人人小站_365体育投注打不开_皇冠365体育投注网址_我要学365体育投注人人小站_365体育投注打不开_皇冠365体育投注网址是一个面向开发者的知识分享网站 365体育投注人人小站_365体育投注打不开_皇冠365体育投注网址
我的位置:首页 > 操作系统>Linux

[Linux] centos6.5升级安装的supervisor

时间:2019-11-08 19:13:00 来源:互联网 作者: 神秘的大神 字体:

因为我要用它来管理多个PHP进程去执行任务,在默认版本下的配置多个子进程不起作用

默认版本的supervisor版本比较低2.1.9,对于运行多个子进程貌似有问题,最新版的supervisor4.1的又因为需要高版本的python才行,所以才有了下面的解决办法

先安装pip
yum install python-pip
再用pip安装3.1版本的supervisor
pip install supervisor==3.1.3
生成配置文件
easy_install supervisor==3.1.3

配置文件

/etc/supervisord.conf

[program:php_imap_daishou]
command=/usr/bin/php /usr/local/sinamail/tools/new/othermail/cli.php entresign
process_name=%(program_name)s_%(process_num)02d
numprocs=10
user=root